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Introduction

This software manual provides a description of how to use the SDS2DPT software. The SDS2DTP
software receives Depth and Altitude data via Sonar Data Stream (SDS) packets transported by UDP/IP
packets over a network connection and retransmits the Depth and Altitude data over a serial port
formatted as a MSDPT NMEA 0183 string.

This manual is separated into several sections: User Interface, Configuring Sea Scan Survwey, Example
Usage, MSDPT String Format, Windows Registry, and Software History.

The User Interface section describes all of the buttons and window controls in the SDS2DPT software.

The Configuring Sea Scan Survey section shows how to configure Sea Scan Surey V4.6.0 and above
with the Data Output feature to send Sonar Data Stream data to the SDS2DPT software.

The Example Usage sections demonstrates using the SDS2DPT software.

The MSDPT String Format section describes the DPT NMEA 0183 string format in detail.

The Windows Registry section describes the usage of the windows registry by the SDS2DPT software.
The Software History section lists all of the versions of the software and the changes made. The versions

are listed newest to oldest.

User Interface

This section introduces the SDS2DPT software's window layout. The window is display below.

SDS 2 $DPT - ¥1.0.0 C2015 o x|

—Cannection
¥ Connect | COM3 <YIRTL, = | @ |4aun =| bps

DP Part: I 1410

—Daka
S0E Source: I SHIP VI
altitude  0.0m
Depth 0.0m

Last Output String:  $MsCPT,0.0,0.0,,*

—Status
@ Serial Connected
@ UDP Connected
. 505 Received
@ ©oPT sent

The window can be broken down into sections:

¢ Connection
e Data
e Status
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2.1 Connection

The Connection section contains all of the settings and controls to initiate a connection to the Network
and to the Serial port.

_onneckion

’:|2 3]
¥ Connect | COM3 <VIRTL, 'I @ | 4300 'rI bps

UDP Pork: I 1410

. Connect Button: Checking this box connects the serial port and network connections.

2. Com Port Selection Box: This box automatically fills up with the available serial ports on the
computer. It allows the user to select an available serial port to connect to.

3. Com Port Baud Rate Selection Box: This box allows the user to select a baud rate to send the
DPT strings at.

4. Network UDP/IP Port: Change the UDP port by typing into this box. This should be set to the same

port as the data output program.

[N

The Serial Connected indicator will turn green when the Connect check box is checked and a successful
connection has been made to the currently selected serial port.

The UDP Connected indicator will turn green when the Connect check box is checked and the
configured UDP port has been successfully opened for receiving data.

These settings are saved in the Windows Registry. They are saved when the application closes. When
the SDS2DPT application is opened again the settings will be restored. If the Connect checkbox was
checked when the application was last closed then the connection to the serial port and network will
automatically be restored.

Please note that USB to Serial converters will enumerate to a different Com port number when plugged
into a different USB port. The conwerter's driver can be setup in advance to enumerate to the same COM
port no matter which USB port it is plugged into however USB hubs make this process much more
complicated. If a USB to Serial converter enumerates to a different Com port number then the SDS2DPT
program will not be able to open the saved Com port automatically on startup.

2.2 Data

The Data section displays the current incoming Altitude and Depth data as well as the last DPT NMEA
0183 string that was sent. In addition to displaying data the section also allows the user to select which
SDS (Sonar Data Stream) source to retrieve the Altitude and Depth data from.

—Data 1
SDS Source? | SOMAR |
attuc2]0.0m

Depth E 0.0m
Last Output 5trir|E|$MEDPT,U.U,u.D,,*
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2.3

w N

. SDS Data Source: Allows the selection of the Sonar Data Stream data source. SONAR is data

from the towfish where Altitude is distance from the towfish to the seafloor and Depth is distance from
the towfish to the surface. SHIP is data from the ship where Depth is the total water depth (distance
from the ship's depth sounder to the sea floor).

. Current Altitude: Displays the current Altitude read from the SDS data in meters.
. Current Depth: Displays the current Depth read from the SDS data in meters.
. Last DPT String Sent: Displays the last NMEA 0183 formatted DPT string sent from the SDS2DPT

program.

The SDS Source setting is stored in the window's system registry. This setting is restored when the

ap

plication is started.

Status

Th

e Status sections displays the current state of the SDS2DPT software. It includes indicators that turn

green when a condition is active.

1

w

C

3| @ sosRecsived
2 @ Pt sent
- |

Latus

O Serial Connected
0 UDP Connected

. Serial Connected: Turns green when the serial port is successfully connected. Turns red when the

serial port is not connected.

. UDP Connected: Turns green when the network is successfully connected. Turns red when the

network is not connected.

. SDS Received: Blinks green when a SDS Fathometer packet is received.
. DPT Sent: Blinks green when a DPT string is successfully sent.

onfiguring Sea Scan Survey

SDS2DPT requires a Sonar Data Stream to be sent to it over UDP/IP packets. This can be

ac

complished using a Marine Sonic Technology Embedded Side Scan Sonar System or Sea Scan

Suney V4.6.0 or newer. Sea Scan Survey V4.6.0 introduced the Data Output feature which streams the
incoming SDS data over a configurable UDP connection.

In

order to successfully send data using Sea Scan Suney the Data Output feature needs to be setup

properly and enabled. Show below is the Data Output Settings page accessible through Sea Scan
Suney's Tools->Settings menu option. For an explanation of all of the controls and settings please see
the Sea Scan Surwey software manual.
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Data Dutput Set

+ hpplication
#]- Master Yiew
lave View

avigation & Fathometer
- Lnits

- Supwey Settings

i Matker Labels

i Data Output

¥ Enahle Data Output
Destination Address: | 127

Destination Part 1409

285 . 285 . 285

1409 - ARC/HDS

x|

Set Defaults

127.255.266 256 - Local Broadcast -

— Sonar Data Stream Optian

™ Include Sonar Data
¥ Include Nav Data

¥ Include Fatho D ata

™ Include NMEA Data

V' Include Drientation Data
I Include Mag Data

I Include Custom D ata

akK | Cancel | Apply | Help |

By default the Enable Data Output check box is unchecked. This means that the Data Output feature is
disabled. To enable the output click the Enable Data Output check box and then click the Apply
button. If no error messages pop up then the output is enabled.

To stream data Sea Scan Survey must be actively recording data. This means that a new survey must
be Created or a survey must be Continued using the File->New or File->Continue Survey menu
options. In addition to this a Sonar Interface must be started and connected as data collection in Sea
Scan Surwey is sonar data centric. This means without sonar data there is no data stream.

In summary to ensure there is a data stream being transmitted:
O Make sure Enable Data Output is Checked.
U Make sure the Destination Port and Destination Address are correct.

O Make sure a Sonar Interface is Started.
U Make sure Sea Scan Survey is Recording Data.

Example Usage

This section demonstrates the setup and usage of the SDS2DPT application.

1) Run the Sea Scan Survey program.

2) Start the Sonar Interface.
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Click on the Tools->Settings menu option. This will open the settings window. Then click on the
Sonar->Interface settings page in the settings tree on the left side of the settings window. Select ARC
Explorer from the Available Interfaces list. Click the Start button. If the button says Stop instead of
Start and the sonar status in the lower right corner of the Sea Scan Survey window shows Sonar
Connected then skip this step as the Sonar Interface is already started successfully.

Available Interfaces

Simulator | St lﬁ.dvanced Settings
HDS Embedded - Metwork

Simple Topside Unit
B Oy Webwork,

3) Create A New Survey.

Click on the File->New menu option. This will open the New Survey window. Click the OK button to
create the suney.

5
select cancel and choose Open From the File menu.
Cancel
1: Select Folder for Seascan Data
C\UsersiChrisFiDocumentsiMy Sonar Data

21 Enker Mame for Survey
20151102

3t Enter data Fils Prefix
2015MOYDZ_

4: Add description

Mo description

The Elapsed Survey Time clock in the lower right corner of the application will begin counting up. If it
does not then please check to see that the Sonar Interface has been started correctly and that the
Sonar Status in the lower right corner says Sonar Connected as shown below.

[ oomoo:io li:unar(:cunnected |

4) Configure the Data Output.

Setup the Data Output Settings in Sea Scan Surwey. The default settings show below are
recommended. Make sure the Enable Data Output checkbox is checked. Click the Apply or OK
button to start the Data Output.
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x
Application .
[+ Master View ¥ Set Defaults
[ Slave Yiew
- Sonar Destination Address: | 127 . 285 . 255 . 2566  127.256.255.255 - Local Broadcast -
[Resauion Destination Port 1403 1403 - ARCHDS -
[#- Mavigation & Fathometer — Sonar Data Stream Optian
Lnits [ Include Sonar Data
- Supwey Settings
.. Marker Labels ¥ Include Nav Data
Data Qukput W Include Fatho Data

™ Include NMEA Data

¥ Include Oriertation Data
I Include Mag Data

I Include Custom D ata

Cancel | Q§ply Help |

5) Run the SDS2DPT program.

6) Configure the Connection Settings.

The exact Com port configuration will vary from computer to computer. In this example we are using
Com1. Make sure the UDP port is set the same as the Data Output feature is set for in Sea Scan
Surwey. In this example the port is set to 1409. The SDS Source should be set for SONAR in order to
capture and convert data from the Sea Scan ARC Explorer Altimeter/Depth Sensor.

el

- Cannection
I™ Connect | comt <virTu, > | @ 4800 | bps

UDP Port: I 1409

—Data
SOS Source: ISON.C\R vI
Alkitude 0.0m
Depth 0.0m

Last Output String:  $MSDPT,0.0,0.0,,*

—Skatus
. Serial Connecked
. UDP Connected
. 505 Received
@ oFT sent
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7) Click the Connect Checkbox.

The Serial Connected and UDP Connected indicators should turn green.

i

—Connection

Iv'[%c-:-nnecqcom <Rt x| @ [4800 | bps
UDP Port: I 1409

—Data

SOS Source: I SOMNAR. vI

alkitude  0.0m
Depth 0.0m

Last ©utput String:  $MSCPT,0.0,0.0,,*

—Skatus
@ Serial Connected
@ IUCP Connecked
. SDS Received
@ oFT sent

8) Start the Sonar.

In Sea Scan Surwey click on the Sonar Power ON button in the Sonar Control Window. This will
start the sonar collecting data.

Sonat Contral Ywindow L

Sonar Power————————————

x
OFF

The SDS Received indicator should turn green and the current sonar altitude and depth readings
should now appear in the Sea Scan Survey Status Window and in the SDS2DPT program's data
section. The DPT Sent indicator should also turn green and the Last Output String in the data
section will reflect the current sonar altitude and depth readings.
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SDS 2 $DPT - ¥1.0.0 C2015

B

alkitude 10,57 m
Depth 9,34 m

Lask Qutput String: $MSDPT,10.57,9.34,,*

Altitude: 1078 m ) OPT Sent

Sonar Depth: 997 m

Sea Scan Survey Status Window SDS 2 DPT Data

9) Open a Serial Terminal program.

Run a serial terminal program and connect to the Com port on the other end of Com port that SDS2DPT
is connected to. In this example SDS2DPT is connected to a virtual serial port COM1 which is wire in
cross over mode to virtual serial port COM2. The terminal program will show the $MSDPT NMEA 0183
formatted strings that SDS2DPT is transmitting as shown below.

ik Termite 3.1 (by CompuPhase) - |EI|5|

|CoMz 115200 bps, &ML, no handshake | Settings || cClear || Abowt || Close |

thASOFT.13.22.9.98, *54 -]
$hSDPT.13.21,9.958, %67
$hSDFT.13.21,9.98, %67
thSOPT.13.21,9.95, %67
thSDFT.13.21,9.95, %67
ShSOPT,13.21,9.98,%67
$hSOPT.13.21,9.95, %67
$hSDFT,.13.20,9.95, *66
$hSDFT.13.20,9.95, 466
thSDFT,.13.20,9.95, %66

-]
| []

5 MSDPT String Format

The DPT string is a NMEA 0183 V1.5 standard string that has been adapted to provide more information.
The NMEA standard DPT string normally contains Water Depth and Transducer Offset from the surface.
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The Marine Sonic (MS) interpretation rearranges the meaning of these values in order to include altitude
data. Currently there are no standard NEMA 0183 strings that convey sonar altitude data. When
sending the MS DPT string the Transducer offset is interpreted as the Water Depth (distance from the
surface to the sonar) and the Water Depth now becomes the Altitude (distance from the sonar to the sea
floor). Adding the values together will result in Total Water Depth (distance from the surface to the sea

floor). Below is an example of this string:

Example:

$MSDPT,<altitude>,<depth>,<max. range scale>* hh<CR><LF>

Format Description:

Name Example Units Description

Start Of String $ $ indicates start of
string

Message ID MSDPT Marine Sonic DPT
string identifier

Altitude <altitude> meters Altitude of the sonar
(Distance from the sea
floor to the sonar).

Depth <depth> meters Depth of the sonar
(Distance from the
surface to the sonar).

Max. Range Scale In Not used.

Use

Checksum Delimeter * The checksum comes
after this character.

hh 2 Digit Hexadecimal Checksum of the entire
string.

Sentence Terminator <CR><LF> Inidicates end of

sentence.

Windows Registry

The SDS2DPT program stores it's settings in the Windows Registry. Below is a highlighted screen
capture of the Microsoft Windows Registry Editor showing the SDS2DPT registry entry. The important

details are highlighted.
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Registry Editor

=18 Computer Marne Tvpe Daka

; REG_SZ {walue not set)
- | HKEY_CURREMT _LISER 8 COM Baud Rate REG_D'WORD Q0000120 {3000
T8 COM Port REG_DWORD 0x00000003 (3)
48| COM Port Connect REG_DWORD 0x00000001 (1)
T8|5D5 Source REG_DWORD 0x00000002 (2)
8| LDP Port REG_DWORD 0x00000552 (1410)

- MSTL

. 5D52DPT

SDS2DPT stores the program settings in HKEY_CURRENT_USER->Software->MSTL->SDS2DPT.

The variables are named according to their corresponding controls in the SDS2DPT program.

7 Software History

V1.0.0 - October 2015
¢ |nitial Version.
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